Running DSC conf from PS5 on PS4

This topic contains 3 replies, has 3 voices, and was last updated by Profile photo of Don Jones Don Jones 10 months, 2 weeks ago.

  • Author
    Posts
  • #34365

    I've made a full solution to install my servers. I use Windows 2012 R2 and PS5 on my main server. When I run my configuration on another Windows 2012 R2 PS5 server it run smooth.
    My problem is when i run on a Windows 2012 R2 PS4. Then I get an error:
    ***************************
    The configuration document with version 2.0.0 cannot be processed by LCM version 1.0.0 because the MinimumCompatibleVersion value is 2.0.0. For the document to be compatible
    with this LCM, the property minimumCompatibleVersion should be set to 1.0.0 in the OMI_ConfigurationDocument instance. Regenerate the configuration document to update the M
    inimumCompatibleVersion property, or upgrade the version of DSC that is running on this computer.
    ***************************

    I've checked my meta.mof file and it it already have the MinimumCompatibleVersion set to 1.0.0
    ***************************
    /*
    @TargetNode='Server3'
    @GeneratedBy=user
    @GenerationDate=01/27/2016 12:52:32
    @GenerationHost=Server1
    */

    instance of MSFT_DSCMetaConfiguration as $MSFT_DSCMetaConfiguration1ref
    {
    CertificateID = "4883F215AF885AEBDDA8CFB059354214013723E6";

    };

    instance of OMI_ConfigurationDocument
    {
    Version="2.0.0";
    MinimumCompatibleVersion = "1.0.0";
    CompatibleVersionAdditionalProperties= { };
    Author="user";
    GenerationDate="01/27/2016 12:52:32";
    GenerationHost="Server1";
    ContentType="PasswordEncrypted";
    Name="Server3";
    };
    ***************************

    Hope someone can help.

  • #34373
    Profile photo of Don Jones
    Don Jones
    Keymaster

    So, when you run a configuration script to produce a MOF, it gets versioned on the authoring machine. That's your problem. You'd need to produce the MOF under WMF4 for it to be valid.

    The error message is a little misleading. I don't think the LCM is actually looking at MinimumCompatibleVersion. I know that's been bugged by others before.

  • #34466
    Profile photo of Brian V
    Brian V
    Participant

    I just ran into the same issue. Any recommendations on development environment setup to run WMF4 & WMF5 side by side? Having to flip flop machines just to do development/generation seems cumbersome.

  • #34468
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Right now, side-by-side isn't possible.

You must be logged in to reply to this topic.