SelfAssigned Scripts to 035

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Mark DiPofi Mark DiPofi 7 months, 2 weeks ago.

  • Author
    Posts
  • #38165
    Profile photo of Mark DiPofi
    Mark DiPofi
    Participant

    I recently made changes to Set-ExecutionPolicy to AllSigned. I am using self assigned singature and trying to run the follow signed script.

    **** Connect to Office 365 ****

    $LiveCred = Get-Credential
    $Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri https://ps.outlook.com/powershell/ -Credential $LiveCred -Authentication Basic -AllowRedirection

    Import-PSSession $Session

    Get-DistributionGroupMember -Identity "accounting"

    —————
    The error I am seeing after I type in my credentials to Office 365 are as follows:

    WARNING: Your connection has been redirected to the following URI: "https://ps.outlook.com/PowerShel
    l-LiveID?PSVersion=4.0 "
    Import-PSSession : Files cannot be loaded because running scripts is disabled on this system.
    Provide a valid certificate with which to sign the files.
    At C:\foo.ps1:7 char:1

    Can you used self assign scripts with o365?

    Thank you

  • #38168
    Profile photo of Don Jones
    Don Jones
    Keymaster

    That's because it's attempting to implicitly remote the O365 commands into your system, and the resulting shadow module doesn't get signed. Not really a workaround for that.

    And even so, a self-signed certificate does nothing for you in terms of security. It isn't trusted, you can't manage revocation, etc. If you're just going to used self-signed, you're pretty much wasting your time with it from a security and integrity perspective anyway.

  • #38173
    Profile photo of Mark DiPofi
    Mark DiPofi
    Participant

    Thank you for the information. I expected you to say the things you have just wanted to verify it.

    I have some research to do now.

You must be logged in to reply to this topic.