Set File Permission (NTFS) using PowerShell DSC

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Arie H Arie H 4 months ago.

  • Author
    Posts
  • #48670
    Profile photo of Hadrean Ocampo
    Hadrean Ocampo
    Participant

    Hi everyone,

    I've used a sample NTFSPermission PS DSC script to manage file sharing. When I used it to Deny users to access a file, it works, but when I reuse the script again to try to revert it (giving back the access), it won't work. Why is that?

    Here's the code:

      configuration SetNTFSPermission
    {
        param
        (
            # Target nodes to apply the configuration
            [string[]]$NodeName = 'localhost',
    
            # Add Account
            [Parameter(Mandatory)]
            [ValidateNotNullOrEmpty()]
            [String]$Account,
    
              # Create a Physical Path
            [Parameter(Mandatory)]
            [ValidateNotNullOrEmpty()]
            [String]$PhysicalPath,
    
            # Add Access
            [Parameter(Mandatory)]
            [ValidateNotNullOrEmpty()]
            [String]$Access,
    
             # Add Rights
            [Parameter(Mandatory)]
            [ValidateNotNullOrEmpty()]
            [String]$Rights
    
        )
    # Import the module that defines custom resources
        Import-DscResource -Module xPSDesiredStateConfiguration
        Node $NodeName
        {
           NTFSPermission NewPermission
            {
                Ensure = "Present"
                Account = $Account
                Access = $Access
                Path = $PhysicalPath
                Rights = $Rights
            }
        }
    }
    
    SetNTFSPermission
    
    
    Start-DscConfiguration -Force -Wait -Verbose -Path .\SetNTFSPermission
  • #48804
    Profile photo of Arie H
    Arie H
    Participant

    I might have missed something but xPSDesiredStateConfiguration has no builtin-resource that deals with NTFSPermissions.

    Are you using a 3rd party DSC resource ?

    Are you using the latest stable version of it, is it sill maintained ?

    Make sure you have the Import command for that module and that its available on the node you want it applied, unless you're using a Pull Server then make sure the module is on the pull server location.

    I suspect you'll need to ask the creator of this module or add the module name and where you got it from so we might
    look into it.

You must be logged in to reply to this topic.