Set-WSManQuickConfig - Cannot find specified file

This topic contains 2 replies, has 2 voices, and was last updated by Profile photo of Przemek Kozak Przemek Kozak 1 year, 4 months ago.

  • Author
  • #26812
    Profile photo of Przemek Kozak
    Przemek Kozak

    OS: Windows Server 2008 R2
    I wanted to Enable-PSRemoting but stuck with error with Set-WSManQuickConfig command.

    After typing Set-WSManQuickConfig in PS Console I get the following error:

    Set-WSManQuickConfig : Cannot find specified file.
    At line:1 char:21
    + Set-WSManQuickConfig <<<< + CategoryInfo : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationExce + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand Firewall is turned off I've search web for answer to no avail. I hope someone here could help me.

  • #26822
    Profile photo of Don Jones
    Don Jones

    Ensure you're running the shell as Admin, and try Enable-PSRemoting.

  • #26843
    Profile photo of Przemek Kozak
    Przemek Kozak

    Hi and thanks for answering,

    I'm running powershell as administrator and when I type Enable-PSRemoting I get error like before:

    WinRM Quick Configuration
    Running command "Set-WSManQuickConfig" to enable this machine for remote management through Wi
    This includes:
    1. Starting or restarting (if already started) the WinRM service
    2. Setting the WinRM service type to auto start
    3. Creating a listener to accept requests on any IP address
    4. Enabling firewall exception for WS-Management traffic (for http only).

    Do you want to continue?
    [Y] Yes [A] Yes to All [N] No [L] No to All [S] Suspend [?] Help (default is "Y"): Y
    Set-WSManQuickConfig : Cannot find specified file.
    At line:50 char:33
    + Set-WSManQuickConfig < <<< -force + CategoryInfo : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationEx + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

    Maybe I'm missing some component on system? I don't know how can I verify this further.

You must be logged in to reply to this topic.