stop dsc push to one server

Tagged: 

This topic contains 3 replies, has 2 voices, and was last updated by Profile photo of Efff dd Efff dd 2 weeks, 4 days ago.

  • Author
    Posts
  • #74455
    Profile photo of Efff dd
    Efff dd
    Participant

    hello
    I currently have a dsc push setup to about 12 servers and I would like to stop it on just one server.
    I removed the server name from the config files but as I'm working on this server its overwriting my changes.

    I see this under the eventviewer

    Job {61DB4905-630D-11E7-80F2-0050568B522} :
    Job runs under the following LCM setting.
    ConfigurationMode: ApplyAndMonitor
    ConfigurationModeFrequencyMins: 30
    RefreshMode: PUSH
    RefreshFrequencyMins: 30
    RebootNodeIfNeeded: NONE
    DebugMode: False

    thanks

  • #74518
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Push mode doesn't happen automatically, unless you've set up a scheduled job to run it. In which case, change the scheduled job.

    Push mode engages when you run Start-DscConfiguration; assuming you're pointing that at a directory full of MOF files, simply delete the MOF file you don't want sent, and it won't send it.

  • #74521
    Profile photo of Don Jones
    Don Jones
    Keymaster

    Unless your problem is that the MOF has been pushed, and you want the LCM to stop applying it. Your current configuration does not re-apply the MOF locally – it "applies (once) and monitors." So the server, locally, should not be repeatedly resetting itself. It's possible some other computer is continually re-pushing the configuration, but you're going to have to figure that out.

    If neither of my comments seem applicable to you, I apologize. If you could share some more details about what you have set up in your environment, I could try to be more specific.

  • #74569
    Profile photo of Efff dd
    Efff dd
    Participant

    thank you
    disabled task under the task scheduler.

You must be logged in to reply to this topic.