'Storage" module commands returns no data on Windows 2016

This topic contains 2 replies, has 2 voices, and was last updated by  Clarence Holbrook 1 week ago.

  • Author
    Posts
  • #81182

    Clarence Holbrook
    Participant

    We are running a mix of Windows 2008R2, 2012R2 and 2016 servers in our environment. We have upgraded a significant portion of them to WMF 5.1. (all the 2016 servers were deployed with WMF 5.1 already installed from a vmware template) I want incorporate the commands from the Storage module (get-command -module storage) for managing disks and partitions.

    The commands I've tested on the 2008R2 and 2012R2 systems work fine. On the 2016 systems, when the command is ran (either locally, or through remote session; elevated or not) it returns no data. No errors, no data, nothing that I can find in any of the logs. I can retrieve the data regarding the disks and partitions through get-wmiobject. I can even return the data using get-ciminstance.

    Has anyone else experienced this issue on 2016 and found a resolution? I'm definitely open for ideas on how to troubleshoot as well.

  • #81362

    Dan Potter
    Participant

    Seems to work find on a 2016 azure vm.

    Is there a particular cmdlet you're having issues with?

    PS C:\Users\dan.potter> Get-PhysicalDisk

    FriendlyName SerialNumber CanPool OperationalStatus HealthStatus Usage Size
    ———— ———— ——- —————– ———— —– —-
    Virtual HD False OK Healthy Auto-Select 30 GB
    Virtual HD False OK Healthy Auto-Select 70 GB

    • #81583

      Clarence Holbrook
      Participant

      I've tried *most* of the commands in the Storage module. Some of the commands take the appropriate amount of time, as if they were processing...however, no data is returned.

      If I run the command with specific data, I get an error message. i.e (get-disk -Number 0) returns "get-disk : No MSFT_Disk objects found with property 'Number' equal to '0'. Verify the value of the property and retry."

You must be logged in to reply to this topic.