Update-Help Access Denied

Tagged: 

This topic contains 6 replies, has 2 voices, and was last updated by  Aaron Leininger 1 month ago.

  • Author
    Posts
  • #77587

    Aaron Leininger
    Participant

    I have a problem very similar (not quite identical) to this one: https://powershell.org/forums/topic/update-help-access-denied-on-domain-controller/

    Mine is on a workstation instead of a DC. I run Update-Help on it and I get this:

    PS C:\userscripts\powershell> update-help
    update-help : Failed to update Help for the module(s) 'GroupPolicy' with UI culture(s) {en-US} : Access to the path
    'C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\GroupPolicy\en-US\Microsoft.GroupPolicy.Commands.dll-help.xml' is denied.
    At line:1 char:1
    + update-help
    + ~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnknownErrorId,Microsoft.PowerShell.Commands.UpdateHelpCommand

    update-help : Failed to update Help for the module(s) 'Provisioning' with UI culture(s) {en-US} : Unable to retrieve the HelpInfo XML file
    for UI culture en-US. Make sure the HelpInfoUri property in the module manifest is valid or check your network connection and then try the
    command again.
    At line:1 char:1
    + update-help
    + ~~~~~~~~~~~
    + CategoryInfo : ResourceUnavailable: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpCommand

    The suggestions in the post I linked to didn't help. Can anyone tell me why I am unable to update those two modules please and how to fix it?

  • #77590

    Aaron Leininger
    Participant

    My post got deleted...Trying again...

    I have a problem very similar (not quite identical) to this one: https://powershell.org/forums/topic/update-help-access-denied-on-domain-controller/

    Mine is on a workstation instead of a DC. I run Update-Help on it and I get this:

    PS C:\userscripts\powershell> update-help
    update-help : Failed to update Help for the module(s) 'GroupPolicy' with UI culture(s) {en-US} : Access to the path
    'C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\GroupPolicy\en-US\Microsoft.GroupPolicy.Commands.dll-help.xml' is denied.
    At line:1 char:1
    + update-help
    + ~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnknownErrorId,Microsoft.PowerShell.Commands.UpdateHelpCommand

    update-help : Failed to update Help for the module(s) 'Provisioning' with UI culture(s) {en-US} : Unable to retrieve the HelpInfo XML file
    for UI culture en-US. Make sure the HelpInfoUri property in the module manifest is valid or check your network connection and then try the
    command again.
    At line:1 char:1
    + update-help
    + ~~~~~~~~~~~
    + CategoryInfo : ResourceUnavailable: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : UnableToRetrieveHelpInfoXml,Microsoft.PowerShell.Commands.UpdateHelpCommand

    The suggestions in the post I linked to didn't help. Can anyone tell me why I am unable to update those two modules please and how to fix it?

  • #77608

    Don Jones
    Keymaster

    The first instance is an Access Denied; check the permissions on the file itself, and ensure you're running As Administrator.

    The second instance is because the module's authors haven't provided online, updateable help. There's nothing you can do about that.

    • #77610

      Aaron Leininger
      Participant

      [edit]I was running an elevated prompt when I got the error. The file permissions on that file appear the same as others in the folder. Nothing seems amiss...

      I thought I had put that in my post. Apologies.

  • #77622

    Don Jones
    Keymaster

    Hmm. Try this, as a diagnostic: Move (not copy) the failing XML file to another location someplace. See if that helps clear it up. The second attempt, if the first fails, would be to move the entire containing folder somewhere else.

    Also, what version of Windows are you using?

  • #77625

    Aaron Leininger
    Participant

    Moving the xml file fails w/ access denied
    Microsoft Windows Enterprise [Version 10.0.15063]

    • #77632

      Aaron Leininger
      Participant

      I got it fixed. Turns out that there was an xml file in the module folder missing. It was similar to the case I quoted but not the same module. Thanks to Don Jones for pointing out the error on the 2nd module wasn't fixable and why!

You must be logged in to reply to this topic.