Update-Help Not Working?

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Daniel Krebs Daniel Krebs 5 months, 1 week ago.

  • Author
    Posts
  • #64188
    Profile photo of Michael Powell
    Michael Powell
    Participant

    I keep getting errors whenever I tried using Update-Help, even in Administrators mode, Is there a way to fix it?

    Here's the error;

    Update-Help -Force
    Update-Help : Failed to update Help for the module(s) 'BitsTransfer' with UI culture(s) {en-US} : The value of the HelpInfoUri key in the module manifest must resolve to a container or root
    URL on a website where the help files are stored. The HelpInfoUri 'https://technet.microsoft.com/en-us/library/dd819413.aspx' does not resolve to a container.
    At line:1 char:1
    + Update-Help -Force
    + ~~~~~~~~~~~~~~~~~~
    + CategoryInfo : InvalidOperation: (:) [Update-Help], Exception
    + FullyQualifiedErrorId : InvalidHelpInfoUri,Microsoft.PowerShell.Commands.UpdateHelpCommand

  • #64233
    Profile photo of Daniel Krebs
    Daniel Krebs
    Moderator

    Unfortunately, you can't fix it because the redirect of the Uri embedded in the shipped module points to the wrong location.

    Get-Module -ListAvailable -Name BitsTransfer | Select-Object -Property HelpInfoUri
    
    HelpInfoUri
    -----------
    http://go.microsoft.com/fwlink/?linkid=390756
    

    I think the best options are to report the problem via the Windows 10 Feedback Hub app and Windows Server UserVoice (https://windowsserver.uservoice.com/forums/295047-general-feedback). The PowerShell team doesn't own this module because the Windows product group has developed it and ships it with Windows.

You must be logged in to reply to this topic.