Upgrading Windows Server Backup snapin

This topic contains 2 replies, has 3 voices, and was last updated by  Don Jones 4 years ago.

  • Author
    Posts
  • #11030

    Tim Lyth
    Participant

    Hi all,

    The company I work for provides managed IT services to a number of clients.
    One of our clients has Windows Server 2008 R2 servers at most of their retail locations, with 2 being Server 2008 (not R2).
    We have developed a Powershell script to perform backups via the Windows PowerShell – I know, not ideal, but as the HO network stores the pertinent data and is backed up via Veeam, it's not super-critical we have anything better at the retail locations, and certainly can't justify the extra cost!

    Unfortunately, at the two locations where they are running Server 2008 instead of 2008 R2, the powershell script doesn't work because the Windows Server Backup Snapin doesn't have the required Cmdlet's.

    All locations have PowerShell v2 installed, but the two problem servers only have v1 of the Windows Server Backup snapin.
    I have read http://technet.microsoft.com/en-us/magazine/ff625835.aspx – this says with v2 most extensions are modules EXCEPT for Windows Server Backup! This means I can't just copy the files across from one of the R2 servers. 🙁
    Without v2 of the snapin, we are unable to upgrade these two locations to using the new PowerShell script which is MUCH more reliable at notifying us of the outcome of the Backup – 100% notification (barring server rebooting during backup and internet connectivity issues) versus 80% (at best!) for the old solution of using a batch file to call a VBScript to send email using CDO.
    I have yet to find an answer through a number of Google searches.

    Is there a way to upgrade the Windows Server Backup snapin/module without upgrading the whole server to 2008 R2?

  • #11035

    Vern Anderson
    Participant

    Not that I am aware of but perhaps you could post what it is that your script actually does and we could help find you another method maybe?

    wbadmin.exe has a ton of command line switches you could use to possibly do the same thing in RTM that you're doing in R2. However I could understand better if you described or shared what the R2 script does.

    -VERN

  • #11036

    Don Jones
    Keymaster

    Unfortunately, modules and snapins are considered a feature of the OS, and they require their specific version of the OS. From a licensing perspective, you're not permitted to copy them to older versions of Windows, even if they function correctly – and in many cases they won't function correctly.

You must be logged in to reply to this topic.