Using Server 2008 R2

Welcome Forums General PowerShell Q&A Using Server 2008 R2

This topic contains 1 reply, has 2 voices, and was last updated by

 
Member
4 years, 6 months ago.

  • Author
    Posts
  • #14855

    Participant
    Points: 0
    Rank: Member

    I could be misinterpreting this but "Learn windows PowerShell in a month of lunches – version 3" states to get the complete functionality of PS version 3 I should install .net 3 and .net 4.

    2012 Server currently has .Net Framework 4.5 and currently has PS version 2 (?) I will update to version 3
    First – Do I need to install .Net 3.5 via Server manager\Features (which installs web services)?

    Second – do I install .Net 3 and .Net 4? (that is if I can even install these versions on the server?)?

    third – should I update to Powershell version4 and still use this book or stay with version 3 while using this book?

    I know these are a lot of guest ions but I need some sincere assistance and greatly appreciate your discernment and experience.

    Thanks
    Steve

  • #14856

    Member
    Points: 0
    Rank: Member

    You need .NET 4.0 to install Powershell 3.0, or.NET 4.5 to install Powershell 4.0. You don't need to worry about earlier versions of.NET unless you need to run Powershell 2.0.

The topic ‘Using Server 2008 R2’ is closed to new replies.