WARNING: Unable to resolve package source ‘https://ci.appveyor.com/nuget/docker

Welcome Forums General PowerShell Q&A WARNING: Unable to resolve package source ‘https://ci.appveyor.com/nuget/docker

Viewing 0 reply threads
  • Author
    Posts
    • #232597
      Participant
      Topics: 1
      Replies: 0
      Points: 12
      Rank: Member

      Hello.

      Studying for 70-740 Exam and not able to get a common script to work. I have exhaustively googled the issue and am still not able find a solution.

      Below is the code I am trying to run. I can get the DockerPS-Dev to download but when I run the Install-Module Docker -Repository DockerPS-Dev -Scope AllUsers -Force , I get the below error.

      # download and install powershell for containers (http://cbt.gg/2uZtKFn)

      Register-PSRepository -Name DockerPS-Dev -SourceLocation https://ci.appveyor.com/nuget/docker-powershell-dev
      Install-Module Docker -Repository DockerPS-Dev -Scope AllUsers -Force

      PS C:\Program Files\Docker> Install-Module Docker -Repository DockerPS-Dev -Scope AllUsers -Force
      WARNING: Cannot access ‘https://ci.appveyor.com/nuget/docker-powershell-dev’. Are you missing ‘Credential’ parameter in the cmdlet?
      WARNING: Unable to resolve package source ‘https://ci.appveyor.com/nuget/docker-powershell-dev’.
      PackageManagement\Install-Package : No match was found for the specified search criteria and module name ‘Docker’. Try Get-PSRepository to see all available
      registered module repositories.
      At C:\Program Files\WindowsPowerShell\Modules\PowerShellGet\1.0.0.1\PSModule.psm1:1772 char:21
      + … $null = PackageManagement\Install-Package @PSBoundParameters
      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      + CategoryInfo : ObjectNotFound: (Microsoft.Power….InstallPackage:InstallPackage) [Install-Package], Exception
      + FullyQualifiedErrorId : NoMatchFoundForCriteria,Microsoft.PowerShell.PackageManagement.Cmdlets.InstallPackage

       

      Here is the output from running the Get-Package command:

      PS C:\Program Files\Docker> Get-PSRepository

      Name InstallationPolicy SourceLocation
      —- —————— ————–
      PSGallery Trusted https://www.powershellgallery.com/api/v2
      DockerPS-Dev Untrusted https://ci.appveyor.com/nuget/docker-powershell-dev

      PS C:\Program Files\Docker> [Net.ServicePointManager]::SecurityProtocol
      Tls, Tls11, Tls12

      • This topic was modified 1 month, 1 week ago by Dan Brooks. Reason: Needed to add more information about what I ran
Viewing 0 reply threads
  • You must be logged in to reply to this topic.