Author Posts

August 22, 2013 at 10:20 am

Anyone know where the pictures next to our forum posts come from, or how to update them? There's nothing photo / avatar related when I bring up the Edit Profile link on this site.

Edit: Based on viewing the page source, it looks like mine's being pulled from Facebook, though I still have no idea how PowerShell.org knew to do that, or how to specify a different picture.

August 22, 2013 at 10:22 am

Gravatar.com, based on whatever e-mail address you supplied us when you created your account.

August 22, 2013 at 10:24 am

Cool, thanks. Gravatar sounds vaguely familiar, so I probably set it up and forgot about it. I'll see if I can get logged on and make changes this evening.

August 23, 2013 at 4:39 am

Strange... I logged on to Gravatar.com, and the photo there doesn't match what I see on PowerShell.org.

August 23, 2013 at 6:16 am

Ah, sorry – you're probably logging in using one of the social networks. We request your photo from the login provider first, and go to Gravatar if it doesn't provide one.

August 23, 2013 at 6:47 am

Doesn't seem to matter. I was logging on with my Live account (and may have originally used Facebook when I signed up for the site. Don't remember). I've reset my PowerShell.org password, logged on directly, and unlinked the account from Live (which was the only one showing up as linked in my profile), but it still seems to be keeping the old photo reference, somehow.

August 23, 2013 at 6:51 am

You logged in with Facebook, or linked your account, or something. Look at the properties of your image on the Web site. It's coming from FB.

August 23, 2013 at 6:59 am

I'm definitely not logged on with Facebook (company proxy server won't allow that). As I mentioned, I was logged on with my Live account, but a few minutes ago, I logged off and signed back on directly with my PowerShell.org username / password.

As far as I can tell from what little information is shown on the "Edit My Profile" page, I'm not linked to anything (see attachment). Before I unlinked it just now, there was a little green check box on the "Live" icon, and now it's gone.

August 23, 2013 at 7:05 am

So, you're photo is indisputably coming from Facebook, something the site couldn't do unless you'd linked the account at some point. Look at the URL the photo's being retrieved from in the HTML source. It's possible you linked at one point and the photo URL's simply being cached. But it's DEFINITELY coming from FB, and unless you'd linked that at some point, the site wouldn't have the URL to pull.

I've got a ton of work to get through today (mortgage bill came, so gotta get on it), so I'm not going to be able to dig into this for you today, but that's what I can tell you right now. All I can probably do is offer to delete your account for you and let you re-create it. I don't have the ability to change those social link/login settings, short of digging into the raw database, which I'm not going to have time to do in the short-term – sorry.

August 23, 2013 at 7:18 am

No worries, this is not a critical thing at all. I just got curious when I couldn't find a setting to change the profile picture on this site.

At some point in the future, it might be nice to have this configurable via the "Edit My Profile" page, instead of happening behind the scenes based on how you originally registered / logged in.

August 23, 2013 at 7:19 am

As soon as someone rewrites the code to do that, I'll let ya know :). If you happen to know PHP and would like to tackle that, speak up!

August 23, 2013 at 7:30 am

I haven't worked with PHP before, but programming is mostly the same all over. Doesn't take too long to pick up a new language. I can look over the existing code, if you'd like, and figure out how complicated it would be to change.

October 2, 2013 at 12:44 am

just testing to see what picture appears next to my post