WinRM failes to connect, is it possible to reset client?

This topic contains 3 replies, has 2 voices, and was last updated by  GS 1 year, 8 months ago.

  • Author
  • #45533



    For some reason any external Wsman communication ends up in error. I try to use Test-Wsman cmdlet on non-existent box and it immeditately fails, if I use real host it fails with the same error message. I can see via network capture that connection is not event attempted to be made. This was working before but stopped working for some reason. I ruled out a bunch of stuff already (network, corrupted user profile, etc), still issue happens. Searched if it's possible to reset Wsman client but did not find a way to do that either. Any ideas where to look else short of reinstalling OS>

    [ADMIN]: PS > test-wsman nonexistentserver
    test-wsman : The WinRM client sent a request to an HTTP server
    and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. 
    At line:1 char:1
    + test-wsman nonexistentserver
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (nonexistentserver:String) [Test-WSMan], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.TestWSManCommand
  • #45538

    Nigel Tatschner

    Have you tried PSExec?

    This is a great way to get around some connection issues

  • #45540


    I need wsman to work, issue is not connectivity since it fails with the same error message for existant and non existant hosts. Connection is not even attempted to be made.

  • #46133


    In case somebody else runs into this.
    Issue turns to be HTTP proxy setup on my machine which was directing HTTP traffic to proxy server instead. Unfortunately Test-Wsman does not allow to specify options for connection to bypass proxy and hence it will fail in such situation.

You must be logged in to reply to this topic.