Author Posts

May 6, 2014 at 12:17 pm

I was looking into some of the DFS cmdlets from powershell 4.0. Technet says the requirements are:
Applies To: Windows 8.1, Windows PowerShell 4.0, Windows Server 2012 R2.
If I install powershell 4.0 on server 2008 R2 can I get access to these cmdlets from there or not? Powershell 4.0 says it is supported on server 2008 R2.

Thanks in advance for any information.

May 6, 2014 at 12:46 pm

No. There's a difference in "version of PowerShell required" and "version of Windows required." Those cmdlets rely on functionality only available in the indicated version of Windows. PowerShell itself doesn't ship with all the OS-level cmdlets.

May 6, 2014 at 12:52 pm

(that said, the Windows 8.1 RSAT may include those cmdlets also, although whether they run against older servers you'd have to test)