WSman Provider – Modify MaxShellRuntime

Welcome Forums General PowerShell Q&A WSman Provider – Modify MaxShellRuntime

Viewing 2 reply threads
  • Author
    Posts
    • #198989
      Participant
      Topics: 3
      Replies: 1
      Points: 26
      Rank: Member

      Hi,

      For testing purpose, I tried to modify MaxShellRuntime from 2147483647 but it showed error message as below. So, It may be read-only value?

       

      Set-Item : The WS-Management service cannot process the request. The configuration setting “MaxShellRunTime” is deprecated and cannot be
      changed. Remove this setting and try again.
      At line:1 char:1
      + Set-Item WSMan:\localhost\Shell\MaxShellRunTime -Value 60000
      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      + CategoryInfo : NotSpecified: (:) [Set-Item], InvalidOperationException
      + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.PowerShell.Commands.SetItemCommand

    • #199235
      Participant
      Topics: 4
      Replies: 70
      Points: 192
      Helping Hand
      Rank: Participant

      I got the same error, but was able to set the property directly:

      (Get-Item WSMan:\localhost\Shell\MaxShellRunTime).value = 60000

       

    • #199289
      Senior Moderator
      Topics: 3
      Replies: 121
      Points: 638
      Helping Hand
      Rank: Major Contributor
Viewing 2 reply threads
  • You must be logged in to reply to this topic.