xWebsite not able to bind SSL cert

This topic contains 1 reply, has 2 voices, and was last updated by Profile photo of Don Jones Don Jones 2 years, 1 month ago.

  • Author
    Posts
  • #19812
    Profile photo of mayuri naware
    mayuri naware
    Participant

    I am trying to set SSL certificate for the website in the website bindings . So I am using xWebsite resource for this , In this when I provide the resource with following details

    xWebsite NewWebsite
    {
    Ensure = "Present"
    Name = $Node.WebSiteName
    State = "Started"
    PhysicalPath = $Node.PhysicalPath
    BindingInfo = MSFT_xWebBindingInformation
    {
    Protocol = "HTTPS"
    Port = 443

    CertificateThumbprint = "1C283E663C0BB5FAE92A83689A85790D2B3DDA0B"
    CertificateStoreName = "MY"
    IPAddress = "172.17.3.112";

    }
    ApplicationPool = $Node.NewWebAppPoolName
    DependsOn = "[File]WebContent"
    }
    I have changed my xWebsite Schema to have MY in place of personal for certificatestore name

    So when I run my configuration , I get the error :

    Failure to add certificate to web binding. Please make sure that the certificate thumbprint
    "1C283E663C0BB5FAE92A83689A85790D2B3DDA0B" is valid.
    + CategoryInfo : InvalidOperation: (:) [], CimException
    + FullyQualifiedErrorId : WebBindingCertifcateError,UpdateBindings

    I have checked the Thumbprint it is a valid one . So please Let me know what is the problem ? Any help is appreciated 

  • #19816
    Profile photo of Don Jones
    Don Jones
    Keymaster

    SSL certificates usually need to be in the machine store, not your personal store, so that IIS can load them.

You must be logged in to reply to this topic.